زیرساخت ابری هایو
[dark-light-mode-switch]

نحوه نصب میکروتیک روی سرور ابری اوبونتو هایو

فهرست مطالب

احتمالاً پیش آمده که نیاز به استفاده از میکروتیک خصوصاً نسخه‌های chr آن داشته باشید.

 

ما در ایمیجهای رسمی خود از ایمیج میکروتیک پشتیبانی نمیکنیم. اما با اسکریپت زیر شما میتوانید یک سرور اوبونتو را فقط در ایران تبدیل به میکروتیک کنید:

 

ابتدا یک سرور ابری اوبونتو ۲۲ بسازید و سپس به آن لاگین کنید.

حالا یک فایل بش اسکریپت بسازید و محتوای زیر را در آن بریزید و با دستور زیر اجرا کنید:

bash script.sh

#!/bin/bash
wget https://download.mikrotik.com/routeros/7.7/chr-7.7.img.zip -O chr.img.zip && \
gunzip -c chr.img.zip > chr.img && \
mount -o loop,offset=512 chr.img /mnt && \
ADDRESS=`ip addr show eth0 | grep global | cut -d’ ‘ -f 6 | head -n 1` && \
GATEWAY=`ip route list | grep default | cut -d’ ‘ -f 3` && \
echo “/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY
/ip service disable telnet
/user set 0 name=root password=xxxxxx”
echo u > /proc/sysrq-trigger && \
dd if=chr.img bs=1024 of=/dev/sda && \
echo “sync disk” && \
echo s > /proc/sysrq-trigger && \
echo “Sleep 5 seconds” && \
sleep 5 && \
echo “Ok, reboot” && \
echo b > /proc/sysrq-trigger

احتمالاً سرور بعد از اجرای اسکریپت فوق یک سری خطا بده، ندید بگیرید و احتمالاً سرور ریبوت نشه که اشکالی نداره میتونید از طریق کنسول هایو اقدام به ریبوت سرور کنید.

دقت کنید حتما بعد از نصب، در بخش جزئیات ماشین نوع بوت را به Non UEFI تغییر دهید.

مستندات نحوه تغییر نوع بوت(bios)

پورت پیش فرض chr، عدد ۸۲۹۱ هست.

 

 

مشکلی بود تیکت بدید همکاران ما کمکتان خواهند کرد.

 

 

رایگان آموزش ببین - آموزش کار با سرویس های هایو

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *